PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : PSR A2000 Midi Kanal 10 Drumsound wechselt auf Pianosound



Shawn
10.07.2015, 21:59
Hallo,
wer kann mir bitte helfen?
Wenn ich über PC ein Midi abspiele im A2000, klingt die Drumspur normal. Sobald ich nur 1x stoppe ist die Drum weg und Pianosound spielt. Kanal 10 wird weiterhin angezeigt. Passiert in Cubase wie in Vanbasco, mit Windows XP und 7, per Midikabel oder USB to Host.
Midi direkt im A2000 abgespielt funktioniert einwandfrei. Mein Fantom XA hat über den PC keine Probleme.
Danke für die Hilfe.

Yado70
11.07.2015, 8:11
Hallo Shawn,

ist das erst kurzfristig aufgetreten, oder früher schon mal?
Schau mal nach, ob dein Midisetup auf All Parts steht.

Shawn
11.07.2015, 10:40
Hallo Dirk,
vielen Dank für die schnelle Antwort.
Den A2000 hab ich seit einem Jahr, benutze Ihn aber erst seit ein paar Tagen.
Habe Midi über PC abzuspielen, also zum ersten Mal ausprobiert. Ein Factory Reset habe ich durchgeführt.
Midi Einstellungen habe ich auf ALL Parts, Key+Style, Master usw. alles ausprobiert. Problem ist das Gleiche.

Shawn
11.07.2015, 11:45
Hallo Dirk,
Problem soweit gelöst,
nach 6h Aufwand am Freitag und 2h heute/Samstag.
Wie immer eine Kleinigkeit.
VanBasco war bei Midi Setup auf Windows, das hat den Fehler verursacht,
der sich auch auf Cubase ausgewirkt hat.
Also nochmal vielen Dank.

t4chris
12.07.2015, 18:29
Hallo Shawn,

ich empfehle, im MIDI-Setting von vanBasco den "Reset Modus" "SYSEX" zu wählen, das zugehörige Textfeld jedoch leer zu lassen. Auf diese Weise ist sichergestellt, dass vonBasco keine eigenen, zusätzlichen GM/GS/XG-Reset-Befehle sendet.

Sollten bei bestimmten Midifiles Probleme auftauchen (z. B. Drum-Kanäle mit Piano-Sound), kann man entweder das entsprechende Midifile nachbearbeiten (GM/XG-Reset setzen bzw. prüfen, dass auch im Drum-Kanal die "richtigen" MSB/LSB/ProgramChange-Werte gesetzt sind), oder man setzt vorübergehend in vanBasco den Reset-Modus auf "General MIDI", "GS" oder "XG" (ausprobieren!).

Viel Erfolg!

Heiko
12.07.2015, 18:55
Hallo,
Piano-Sound anstatt Drums weist fast immer darauf hin, dass der Klang vom Microsoft Soundchip des PCs erzeugt wird und der MIDI-Port zum Keyboard nicht geschaltet ist.

Insbesondere die neueren Windows-Systeme können nichts mit Ctrl. 0 (MSB), Ctrl. 32 (LSB) und ProgramChange für die XG-Drumsets anfangen. Sie ignorieren bei Kanal 10 die Controller und verwenden Prg-Chg mit dem Wert 0, wodurch das "Acoustic Grand Piano" von GM angesteuert wird.
Gruß Heiko