PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : SysEx-Daten für XG-on



Karl-Heinz_Keller
30.08.2001, 22:43
Hallo Freunde,

ich versuche in der Eventliste die LSB-Zuordnung zu den Programmnummern zu machen um an die Sounds des PSR 9000 zu kommen. Mit Logic-Audio von Emagic beim Rolandmodul SC8820 hat das immer problemlos funktionniert, nur hier bekomme ich keine Soundreaktion. Ich habe diese Frage bereits schon einmal gestellt, vielleicht kann mir jemand sagen, welche XG-Befehle ich im Sys-Ex-Bereich eingeben muß um an die Sounds vom PSR 9000 zu kommen.

Gruß
Karl-Heinz

Peter-Schips
31.08.2001, 0:40
Hallo Karl-Heinz,

dreh doch den Spiess einfach mal um. Lasse die DEMO-Files abspielen und nehme diese mit deinem Sequenzerprogramm auf, danach kannst Du die wesentlichsten Daten entnehmen.

Wie Du die MSB/LSB und Progr. Change Nummer setzen kannst und wie man an die Nummer kommt, hatten wir besprochen.

MIDI-Bank Select unter Function !!!

Einem XG-SysEx Header sollte immer ein GM on vorangehen - ich mache Dir mal ein Screenshot........"please hold the Line" http://www.yamaha.de/ubb/images/icons/grin.gif

Gruß/Peter http://www.yamaha.de/ubb/images/icons/grin.gif

Peter-Schips
31.08.2001, 0:48
So......nu abba :

Schau Dir das mal an !!!

http://people.freenet.de/Flash-Projekt-2001/Header_1.jpg

oder das :

http://people.freenet.de/Flash-Projekt-2001/Header_2.jpg

Gruß/Peter http://www.yamaha.de/ubb/images/icons/grin.gif

PS: Sag Bescheid wenn`s jetzt klappt oder auch nicht !!!

[Dieser Beitrag wurde von Peter-Schips am 30. August 2001 editiert.]

Clemens
31.08.2001, 0:51
Ja, der Peter war schneller http://www.yamaha.de/ubb/images/icons/grin.gif

Und seine Idee ist sehr gut. Hätte ich auch nicht besser beantworten können http://www.yamaha.de/ubb/images/icons/grin.gif

Gruß

Clemens

Peter-Schips
31.08.2001, 11:40
Hi Clemens,

merci für die Blumen - war mir nicht gaaanz so sicher. Ich Sequenze nicht sooo viel.

Nu gut - wir werden sehen ob`s der Karl-Heinz jetzt hinbekommt.

Gruß/Peter http://www.yamaha.de/ubb/images/icons/grin.gif

Karl-Heinz_Keller
31.08.2001, 12:07
Hallo Peter, Hallo Clemens,

ich sitze nicht nur am Keyboard bzw. im Forum und deshalb bin ich erst jetzt dazu gekommen, alles auszuprobieren.

Also: !Es funktioniert!

Ich habe in allen Midifiles die SysEx-Daten von Roland mit hineingeschrieben. Ich dachte, daß die Roland-SysEx-Daten von von Yamaha ignoriert werden würden. Dieses ist offenbar der Irrtum gewesen. Ich muß die Rolanddaten löschen und nur Yamahadaten eintragen. Dann funktioniert die Sache.

Besten Dank für die Hilfe und ich sehe in diesen Hilfen die tatsächliche Notwendigkeit des Forum.

Also das Problem ist erkannt, würde mich trotzdem interessieren, ob jemand auch Erfahrung hat, mit gemischten SysEx-Daten.

Ich helfe auch gerne bei Problemen.

Gruß
Karl-Heinz

Clemens
31.08.2001, 18:15
Hallo Karl-Heinz,

das mit "gemischten" SysEx-Daten ist so eine Sache. Wie du sicher schon erkannt hast, sollte nach einem XG-On-befehl kein GS-ON oder GM-ON folgen, sonst wird die PSR9000 oder ein anderer XG-kompatibler Klangerzeuger wieder auf den GM bzw. TG-Mode (der GS-ähnliche Mode von XG-Synthies) zurückgesetzt.

Auch die Reihenfolge anderer SysEx-Befehle ist ab und an genau einzuhalten.

Wer mit der PSR9000 selbst MIDI-Songs abmischt hat gute Karten, da die PSR die vorhandenen SysEx-befehle in MIDI-Songs analysiert und korrekt hinzufügt bzw. ersetzt.

Aber auch mit XG-Works hat man im Großen und Ganzen den Überblick beim Thema SysEx.

Gruß

Clemens