Ankündigung

Einklappen
Keine Ankündigung bisher.

Kein Bass (Mega Voice) nach Editieren

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Kein Bass (Mega Voice) nach Editieren

    Hallo zusammen,

    habe da ein ganz seltsames Problem:

    Nachdem ich ein D-O-O Midifile mit Steinberg Cubase Vers. 6 editiert habe, wird die Mega Voice (ein Bass auf Spur 4) nicht mehr erkannt. Statt dessen wird beim Abspielen ein Orgel gespielt. An den Program Changes oder irgendwelchen Control Changes habe ich NICHTS verändert. Das Midifile wurde lediglich um 2 weitere Spuren für das Hallgerät und den Vocalisten erweitert.

    Kann es sein, dass Mega Voices durch Softwareprogramme so verändert werden, dass die Stimmen nicht mehr erkannt werden? Liegt es vielleicht an Steinberg Cubase, dass beim Speichern wichtige Informationen verloren gehen?

    Hoffe, mein Problem verständlich erklärt zu haben und freue mich auf jede Info.

    Viele Grüße
    muggel74

    #2
    Re: Kein Bass (Mega Voice) nach Editieren

    Hallo Muggel,

    zwei Fragen:
    1. Wo spielst Du das neue Midifile ab? Am PC oder am Key? Wenn Du keine MIDI/USB Kopplung zum Keyboard verwendest, spiel das Midifile direkt mit dem Keyboard ab.
    2. Hast Du beim Einfügen der beiden zusätzlichen Spuren darauf geachtet, dass Du dafür auch zwei freie Midikanäle verwenden musst? Speicher das File mal im Format 0 (SMF 0 oder MIDI 0) ab und lade es erneut. Sind alle Spuren noch da?

    Wenn Du weiterhin nicht klar kommst, dann schick mir mal die Midifiles im Zustand vorher und nachher zu.
    heikoplate<at>gmx.de
    <at> durch @ ersetzen

    Gruß Heiko
    hpmusic: http://www.heikoplate.de/mambo

    Kommentar


      #3
      Re: Kein Bass (Mega Voice) nach Editieren

      Hallo muggel,

      ich gehe davon aus, dass du das Midifile in Cubase abspielst.

      Das Problem ist mir bekannt. Eine Lösung ist in Sicht:

      Das Problem tritt auf, wenn der Programmchange-Befehl vor den beiden SysExen "XG-On" und "Turn General Midi On" kommt.

      Ich behelfe mir folgendermaßen:
      Der Part, der die beiden SysExe enthält, ist einen Takt lang und beginnt auf 1.1.0.

      Bei allen anderen Spuren werden die Parts ggfs. nach dem 1. Takt zerschnitten, die jeweils ersten Takte jeder Spur auf 1.2.0 oder 1.3.0 verschoben und entprechend gekürzt, so dass das Ende jeweils bei 2.1.0 ist.

      Programmchangebefehle, die sich in den jeweils ersten Takten befinden, kommen damit garantiert nach den beiden genannten SysExen und damit erklingen die richtigen Voices.
      Gruß Rainer

      www.go4musik.de

      Kommentar


        #4
        Re: Kein Bass (Mega Voice) nach Editieren

        Hallo Heiko, hallo Rainer,
        herzlichen Dank für das Feedback.

        @Heiko: ich spiele das File von einem Miditemp MSX ab, nachdem ich 2 neue Spuren für die Steuerung des Halls und des Vocalisten erzeugth habe. Das ist in der Regel nochmal der Kanal 15 und 16. Diese werden über das Routing dann dem Ausgang 2 zugewiesen, welche die beiden in Reihe geschaltenen Geräte ansteuern.

        Nach dem Abspeichern in Cubase sind noch alle Spuren da. Das mache ich seit nun 22 Jahren. Allerdings früher häufiger mit GM und GS Geräten.

        @Rainer: Ich kann mir gut vorstellen, dass es an dem SysEx Befehl liegt, der vermutlich zu spät gesendet wird und somit die Voice nicht richtig umstellt. Was ich dabei allerdings nicht verstehe ist, dass ich weder an der Zählzeit der SysExe etwas geändert habe, noch an den Program Changes der Bass-Spur.

        Geändert bzw. hinzugefügt wurde lediglich 2 neue Spuren und die haben mit der Bass-Spur überhaupt nichts zu schaffen.

        Ich werde das File aber hinsichtlich der zerschnittenenen Parts und dem Beginn der Program Changes prüfen. Das scheint mir das noch logischtes zu sein.

        Bei Cubase 6 und den Versionen dafür bin ich mir aber nicht mehr so ganz sicher, ob denn das ganze XG Gedöns durch das Editieren und Speichern nicht in seiner "Form" verändert wird.

        Wie gesagt, bei GM und GS gab es sowas nicht. Es seit ich ein Tyros 3 habe und die Midifiles dafür anpasse passiert das.

        Ein Beleg dafür ist, dass bis zu Cubase 5 nach dem Zerschneiden von Parts sämtliche XF Akkorde einfach aus dem Midifile gelöscht wurden. Erst mit Cubase 6 bleiben nach dem Editieren die XF Akkorde im Midifile.

        Ich tippe also ganz stark auf Cubase.

        Ich möchte aber garnicht ausschließen, dass das Problem in diesem Fall vielleicht sogar vor dem Rechner sitzt.

        Vielen Dank für Eure Unterstützung.

        @Heiko: wenn ich nicht dahinter komme, dann bekommst du die beiden Files natürlich zur Prüfung zugestellt.

        Bis bald
        Muggel

        Kommentar


          #5
          Re: Kein Bass (Mega Voice) nach Editieren

          Hallo Muggel,
          meine Frage 1 zielte darauf hin, ob der Sound vom PC oder vom Keyboard erzeugt wird. Der Klangerzeuger von PC Soundchips kann mit Mega Voices nichts anfangen.

          Dann noch: Wenn das Problem an falsch positionierten SysEx / Program Change liegt, sollte eine PSRUTI-XG-Optimierung den Fehler beheben.
          Gruß Heiko

          Nachtrag:
          Wenn Du Dich mit MIDI Events ein bisschen auskennst, könntest Du auch den Bereich vor der ersten Note vom Kanal 4 mit meinem Programm PSRMIDI untersuchen. Homepage s. u.
          Passende Instrumentendefinition tyros_kbds.ins aus Downloads - CW Ins-Files verwenden.
          hpmusic: http://www.heikoplate.de/mambo

          Kommentar


            #6
            Re: Kein Bass (Mega Voice) nach Editieren

            Hi
            Bei Cubase 6 und den Versionen dafür bin ich mir aber nicht mehr so ganz sicher, ob denn das ganze XG Gedöns durch das Editieren und Speichern nicht in seiner "Form" verändert wird.

            An Form und Lage der Controller wird vom Programm nichts geändert da kannst du 100% sicher sein
            Es gibt nur 2 Möglichkeiten:
            Der Befehl fehlt, das musst du untersuchen
            Du hast ihn gelöscht.

            Hast du das File mal gespeichert und dann abgepielt?
            Wenn du Takte trennst und die Funktion "Following Events" aktiv ist, kommt es auch zu solchen Erscheinungen, weil Cubase dann nur bis zum Schnitt schaut.
            Pele

            >> Humor ist ein Midi Live zu spielen <<

            Kommentar

            Lädt...
            X