Ankündigung

Einklappen
Keine Ankündigung bisher.

PSR S-975 - Mixing ändern / Midifile Optimizer?

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    PSR S-975 - Mixing ändern / Midifile Optimizer?

    Hallo Leute,
    irgendwie stehe ich beim PSR 975 auf dem Schlauch.
    Ich ändere mit der Mixing Console ein Midifile und weise Ihm ein Custom Drumkit zu. Dann gehe ich in de Song Creator, spule den Song mit "Stop" auf Anfang und gehe nach Channel.
    Dann Execute und Save. Jetzt ist der Controler für das User Drumkit geschrieben. Beim Abspielen im PSR 975 klappt das auch. Wenn ich den Song dann aber im Midifile Optimizer abspiele,
    habe ich das User Drumkit nicht drin, sondern nur ein Standard Drumkit. Müsste aber doch sein, weil das Keyboard es auch anwählt und anscheinend die Bank- und Programmchange Informationen drin sind.
    Wo mache ich denn einen Fehler?

    Gruss
    Siggi
    King Size Siggi

    http://www.siggiraskop.de

    #2
    Zitat von King_Size_Siggi Beitrag anzeigen
    ... Ich ändere mit der Mixing Console ein Midifile und weise Ihm ein Custom Drumkit zu. Dann gehe ich in de Song Creator, spule den Song mit "Stop" auf Anfang und gehe nach Channel. Dann Execute und Save. Jetzt ist der Controler für das User Drumkit geschrieben. Beim Abspielen im PSR 975 klappt das auch.

    Wenn ich den Song dann aber im Midifile Optimizer abspiele, habe ich das User Drumkit nicht drin, sondern nur ein Standard Drumkit. Müsste aber doch sein, weil das Keyboard es auch anwählt und anscheinend die Bank- und Programmchange Informationen drin sind.

    Wo mache ich denn einen Fehler?
    Hallo Siggi,

    zunächst "vorsichtshalber" die Frage: Du hast beim Abspielen des Files im Optimizer aber schon das PSR per MIDI mit dem PC verbunden?

    Nutzt du USB-MIDI oder arbeitest du mit einem externen MIDI-Interface am PC? Wichtig ist, dass die Wiedergabe-Daten im Optimizer auf die SONG-Parts des PSR-975 geroutet sind. Im Falle von USB-MIDI muss also im Optimizer der Anschluss "Digital Workstation 1" als MIDI-Ausgang eingestellt sein..

    Hast du kontrolliert, ob das "richtige" MIDI-Setup eingestellt ist (z. B. "All Parts" oder "KBD & STYLE")?

    Als Instrument hast du im Optimizer vermutlich das PSR-S970 eingestellt. (Das S975 wurde ja meines Wissens bisher von Victor noch nicht eingepflegt.)

    Grundsätzlich empfehle ich, unter "Einstellungen - Optionen" die beiden Haken "Sounds automatisch anpassen" und "SysEx automatisch anpassen" GESETZT zu lassen. Du könntest aber auch den erstgenannten Haken auch mal testweise ENTFERNEN. Möglicherweise ersetzt der Optimizer ja fälschlicherweise die (ihm unbekannte) Custom-Drum-Voice durch ein Standard-Kit, wenn die zu verwendenden Custom-Kits im Optimizer nicht explizit eingepflegt wurden (wie es z. B. beim T5 und Genos möglich ist).

    Ist sichergestellt, dass es sich beim dem im Optimizer abgespielten File wirklich um die Version handelt, die zuvor am Keyboard geändert wurde?

    Hast du schon mal im Optimizer in der Eventliste nachgesehen (Button "Spur")? Wird dort auf dem Drum-Kanal bei Controller 0 "Bank MSB=62" sowie bei Controller 32 der "richtige" LSB-Wert angezeigt (so wie am Keyboard bei der betreffenden Custom-Drum-Voice bzw. im YEM unter "Change Bank Select LSB" für das betreffende Pack angezeigt)?


    P.S.
    Verwendest du die aktuelle Version des Optimizers (V10.7.1.13530)?

    P.P.S
    Im Titel dieses Threads steht irrtümlich dein NAME. Da man mit normalen User-Rechten meines Wissens den Thread-Titel nachträglich nicht mehr ändern kann, bittest du am besten den Moderator (per PN) darum.
    Zuletzt geändert von t4chris; 29.07.2019, 18:22.
    Gruß
    Christian

    Alle sagten immer: "Das geht nicht!" . Doch dann kam jemand, der dies nicht wusste – und hat es einfach gemacht ...

    Kommentar


      #3
      Zitat von King_Size_Siggi Beitrag anzeigen
      Hallo Leute,
      irgendwie stehe ich beim PSR 975 auf dem Schlauch.
      Ich ändere mit der Mixing Console ein Midifile und weise Ihm ein Custom Drumkit zu. Dann gehe ich in de Song Creator, spule den Song mit "Stop" auf Anfang und gehe nach Channel.
      Dann Execute und Save. Jetzt ist der Controler für das User Drumkit geschrieben.
      Beim Abspielen im PSR 975 klappt das auch. Wenn ich den Song dann aber im Midifile Optimizer abspiele,
      habe ich das User Drumkit nicht drin, sondern nur ein Standard Drumkit. Müsste aber doch sein, weil das Keyboard es auch anwählt und anscheinend die Bank- und Programmchange Informationen drin sind.
      Wo mache ich denn einen Fehler?

      Gruss
      Siggi
      Hallo
      Also ich vermute, das Problem liegt nicht am Optimizer, sondern wie Du im Key das Midi speicherst.
      Deine Art zu speichern war beim 950er ok. Ab dem 970er muß man nach der Midibearbeitung auf den Reiter Setup gehen, dann auf Apply drücken und dann speichern.
      Denke mal das ist beim 975er eben so. Anders werden deine Änderungen im MIDI nicht gespeichert.
      Dann kannst Du die Änderung auch nicht im Optimizer sehen.
      PSR-S970
      Gruß malemik
      In der heutigen Zeit die Wahrheit zu sagen,
      wird oft als revolutionärer Akt betrachtet.

      Kommentar


        #4
        Hallo Siggi, an der Bezeichnung des Threads ist dein Problem, bzw. deine Frage nicht ersichtlich.
        Damit machst du es anderen Usern mit dem selben Problem schwer eine Antwort zu finden und andere User, die dir ggf. helfen könnten, werden deinen Thread nicht anklicken.
        Also bitte immer in der Thread-Bezeichnung „Keyboard - Problem“ angeben.
        Bitte sende mir per PN eine aussagekräftige Bezeichnung und ich ändere dann den Thread.
        Moderator
        Keyboard Forum
        YAMAHA Music Europe GmbH

        Kommentar


          #5
          Hallo T4 Chris,

          Deine Erklärung hat das Problem gelöst. Ich muss beim Optimizer die beiden Häkchen wegklicken.
          vielen Dank
          Siggi
          King Size Siggi

          http://www.siggiraskop.de

          Kommentar


            #6
            Zitat von King_Size_Siggi Beitrag anzeigen
            Hallo T4 Chris,

            Deine Erklärung hat das Problem gelöst. Ich muss beim Optimizer die beiden Häkchen wegklicken.
            vielen Dank
            Siggi
            Hallo Siggi,

            danke für die positive Rückmeldung!


            P.S.
            Normalerweise müsste es in diesem Fall reichen, nur den Haken bei "Sound automatisch anpassen" zu entfernen (also den Haken bei "SysEx automatisch anpassen" gesetzt zu lassen).

            Wenn du allerdings ein File, das für ein anderes Instrument programmiert wurde, zum ersten Mal im Optimizer lädst, empfehle ich, diese BEIDEN Haken vorher wieder zu SETZEN, damit der Optimizer eben automatisch die ggf. nötigen Anpassungen vornehmen kann.

            Gruß
            Christian

            Alle sagten immer: "Das geht nicht!" . Doch dann kam jemand, der dies nicht wusste – und hat es einfach gemacht ...

            Kommentar

            Lädt...
            X