Ergebnis 1 bis 10 von 10

Thema: GENOS - Midi-Song wird wiederholt

  1. #1

    GENOS - Midi-Song wird wiederholt

    Wenn ich auf meinem GENOS einen Midi-Song spiele und wähle dann den nächsten Song an, dann wird der voherige Song wiederholt.
    Das passiert bei mehreren und immer den selben Songs. Ich kann dann auch keinen weiteren Song anwählen.

  2. #2
    Senior Member Avatar von t4chris
    Registriert seit
    01 2012
    Ort
    Bayern
    Beiträge
    9.806
    Hallo Anfänger36,

    vermutlich ist im vorliegenden Fall "nur" der "Repeat"-Modus eingeschaltet.

    Schau doch mal im Genos-Referenzhandbuch auf Seite 58 nach ("Verwenden des Repeat-Playback-Modus ...").

    Die Vorgehensweise zum Ein-/Ausschalten unterscheidet sich etwas, je nachdem, ob du im "Dual-Player-Modus" oder im "Songlisten-Modus" arbeitest.
    Gruß
    Christian


    Alle sagten immer: "Das geht nicht!"
    . Doch dann kam jemand, der dies nicht wusste – und hat es einfach gemacht ...

  3. #3
    Hallo Christian,
    im Dual-Player-Modus ist der Repeat-Modus ausgeschaltet. Meine Midis und Styles starte ich von einem Stick.
    Gruß
    Franz

  4. #4
    Senior Member Avatar von t4chris
    Registriert seit
    01 2012
    Ort
    Bayern
    Beiträge
    9.806
    Hallo Franz,

    • hast du auch geprüft, ob diese "Repeat"-Funktion evtl. von einem derartigen Midifile selbst eingeschaltet wird?

    Der Status der "Repeat"-Funktion kann zwar lt. Genos Data List nirgends gespeichert werden (z. B. in Registrationen oder direkt im Midifile). Möglicherweise gibt es aber einen undokumentierten Befehl (SysEx) dafür.

    • Ist auch sichergestellt, dass das Problem nicht von der aktivierten "Phrase Mark Repeat"-Funktion kommt (Wiederholung bestimmter, durch Marker im File festgelegter Abschnitte)? Siehe hierzu auch S. 66 im Genos Referenzhandbuch ("Song Setting - Play").

    • Bitte auch im Player-Display die Funktion "Song Position - Loop" (siehe auch im Genos Handbuch, S. 78 bzw. 81) kontrollieren.

    • Wenn das Problem weiterbesteht und definitiv nur bei ganz bestimmten Midifiles auftritt, müsste man diese Files mal genauer unter die Lupe nehmen. Ein erster Ansatzpunkt wäre, ob diese Files vielleicht nach dem Ende der letzten Note noch relativ lange weiterlaufen. (Es gibt immer wieder Files, wo der END-Marker viel zu weit hinten sitzt.)

    Falls noch nicht geschehen, empfehle ich zunächst mal eine XG-Optimierung dieser Files in PSRUTI vorzunehmen. Dies kann nie schaden, bitte aber das bearbeitete File jeweils unter neuem Namen speichern!

    Dann würde ich mal in PSRUTI die SysEx in eine Textdatei auslesen (auch die SysEx im Notenbereich) sowie parallel dazu das File (vor allem die SysEx) in MixMaster und im Optimizer analysieren (z. B. jeweils in der Eventlisten-Ansicht). Möglicherweise findet sich ja hier etwas "Auffälliges".
    Geändert von t4chris (02.11.2018 um 18:14 Uhr) Grund: Tippfehler
    Gruß
    Christian


    Alle sagten immer: "Das geht nicht!"
    . Doch dann kam jemand, der dies nicht wusste – und hat es einfach gemacht ...

  5. #5
    Kopiere auf einen leeren Stück 3 Midifile egal welch und teste das gleich nochmal ob er wiederholt oder nicht.
    Nimm keine registration und schalte dein Keyboard neu ein vor dem Test dann hast du schon mal 50 % eingegrenzt wo der Fehler herkommt.
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

  6. #6
    Drei Midifiles habe ich auf einen Stick kopiert und dann war gar nichts zu hören. Ich konnte nicht mal einen Song starten.

  7. #7
    Senior Member Avatar von t4chris
    Registriert seit
    01 2012
    Ort
    Bayern
    Beiträge
    9.806
    Hallo Franz,
    Zitat Zitat von Anfänger36 Beitrag anzeigen
    Drei Midifiles habe ich auf einen Stick kopiert und dann war gar nichts zu hören. Ich konnte nicht mal einen Song starten.
    irgendwie sieht sieht es aus, als ob hier mehrere unterschiedliche Probleme zusammenkommen.

    Es sollte dir doch möglich sein, einige Midifiles (von denen du weißt, dass sie ordnungsgemäß funktionieren) auf einen Stick zu kopieren und diese auch abzuspielen (?)
    Gruß
    Christian


    Alle sagten immer: "Das geht nicht!"
    . Doch dann kam jemand, der dies nicht wusste – und hat es einfach gemacht ...

  8. #8
    Das habe ich vermutet . Denn der loopbtritt auf wenn er auf dem im Puffer vorhandene Mididaten greift.

    Dann ist auch der Zugriff über den Stick mit neuen Daten nicht sauber.
    Formatiert den Stick auf alle fälle am Keyboard!.
    Wenn nicht schön geschehen

    Alternativ kopiere 3 Midifiles in den User Speicher und Versuch das gleiche ob hier der Zugriff auch nicht möglich ist.
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

  9. #9
    Nachdem ich den Stick am Genos formatiert und die Daten wieder installiert habe, besteht weiterhin das gleiche Problem.

  10. #10
    Wenn wie beschrieben der Genos in den Urspurng zurück versetzt wurde und wie du schreibst die Files auch weiterhin im Loop abgespielt werden dann stimmt mit deiner Hardware etwas nicht. Denn 3 saubere Files, ein neu formatierter Stick und ein zurückgesetzter Genos. Würden immer die Files sauber abspielen und der Aufruf des nächsten File würde funktionieren!

    Kontatkiere deinen Händler oder eine Servicewerkstatt dass sie definitiv das prüft ob es wirklich an der Hardware liegt!
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •